SquirrelMail  
Donations
News
About
Support
Screen shots
Download
Plugins
Documentation
Sponsors
Bounties













Security Notice
Phishing campain
Version 1.4.15
Security Upgrade
Plugins - Change Password
Category: Change password

Works with a compatible poppass daemon to allow users to change their passwords.
Note: This plugin should not be used with any of the 1.5.0+ versions of SquirrelMail. The functionality it provides is already a part of 1.5.0+.


Version 3.1
by Seth Randall on Dec 9, 2009
[ change_pass-3.1-1.4.0.tar.gz tarball (23853 d/l) Help ]
Requires: SquirrelMail 1.4.0+ and Compatibility 2.0.16+ or SquirrelMail 1.4.20+, poppassd server

Description:
  • Added support for smtoken

Older versions

Version 3.0
by Seth Randall on May 14, 2009
[ change_pass-3.0-1.4.0.tar.gz tarball (8220 d/l) Help ]
Requires: SquirrelMail 1.4.0+ and Compatibility 2.0.13+ or SquirrelMail 1.4.16+, poppassd server

Description:
  • Redesign and significant rewrite
  • New strings to match strings in SquirrelMail Devel Warning: Until the translations are updated by the I18N team, this plugin has no translations
  • Password length limits
  • Produces correct error messages for password change failure


Version 2.7a-1.4.x
by Seth Randall on Jun 10, 2007
[ change_pass-2.7a-1.4.x.tar.gz tarball (21061 d/l) Help ]
Requires: SquirrelMail = 1.4.x, poppassd

Description: This is a documentation and translation update. None of the functionality has changed from 2.7-1.4.x.
Changes:
  • Added Korean translation by LEE CHANG MIN.
  • Added Dutch translation by Sander Eerkes.
  • Added Swedish translation by Erik Lindgren.
  • Added Norwegian Bokmal translation by Svein Olav Bjerkeset. SquirrelMail tracker #1525721.
  • Added FAQ
  • Updated INSTALL and README files
  • Added Slovenian translation (sl_SI) from "Sasa Stupar.
  • Added Czech translation (cs_CZ) from "Martin Ć louf".
  • Updated Italian translation (it_IT) from "Salvatore Bocchetti".
  • Added Finnish translation (fi_FI) from "Kari Mattsson".
  • Added Italian translation (it_IT) from "magomarcelo".


Version 2.7-1.4.x
by Seth Randall on Jul 22, 2004
[ change_pass-2.7-1.4.x.tar.gz tarball (64048 d/l) Help ]
Requires: SquirrelMail > 1.4.x, poppassd

Description:
  • Added option to specify a poppass server if it's different than the imap server
  • Added Brazilian Portuguese translation (pt_BR) from "Edinardo Potrich"


Version 2.6-1.4.x
by Seth Randall on Dec 18, 2003
[ change_pass-2.6-1.4.x.tar.gz tarball (16552 d/l) Help ]
Requires: SquirrelMail > 1.4.x, poppassd

Description:
  • Minor updates to some translations
  • Added French translation (fr_FR) from "Ludovic Marcotte"
  • Changed version number to 2.6-1.4.x


Version 2.5-1.4.x
by Seth Randall on Dec 7, 2003
[ change_pass-2.5-1.4.x.tar.gz tarball (3998 d/l) Help ]
Requires: SquirrelMail > 1.4.x, poppassd

Description:
  • Added German translation (de_DE) from "Steffen Beyer"
  • Accept 3xx codes after pass command (arguably wrong, but the poppass daemon in the ports collection does it that way)
  • Added Bulgarian translation (bg_BG) from "Marian Popov"


Version 2.4-1.4.x
by Seth Randall on Oct 20, 2003
[ change_pass-2.4-1.4.x.tar.gz tarball (5743 d/l) Help ]
Requires: SquirrelMail >= 1.4.0

Description:
  • Added Polish translation (pl_PL) from "Sebastian Turzynski"
  • Added Spanish (es_ES) translation from "grana canal10"
  • Explicitly define SQ_SESSION as the source of onetimepad


Version 2.3-1.4.x
by Seth Randall on Sep 22, 2003
[ change_pass-2.3-1.4.x.tar.gz tarball (4709 d/l) Help ]
Requires: SquirrelMail >= 1.4.x

Description:
  • Added translation support (thanks to Ruben Leote Mendes)
  • Added Portuguese (Portugal) (pt_PT) translation from "Ruben Leote Mendes"
  • Added change_pass_version in setup.php


Version 2.2-1.4.x
by Seth Randall on Jul 17, 2003
[ change_pass-2.2-1.4.x.tar.gz tarball (5284 d/l) Help ]
Requires: SquirrelMail >= 1.4.0

Description: Removed poppassd software. Added links in README to poppassd software Correctly handle 2xx/3xx return codes.

Version 2.1-1.4.x
by Seth Randall on Apr 25, 2003
[ change_pass-2.1-1.4.x.tar.gz tarball (6413 d/l) Help ]
Requires: SquirrelMail >= 1.4.0

Description: Fix so 300 replies work properly. Added version file.

Version 2.0-1.4.x
by Seth Randall on Apr 7, 2003
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: SquirrelMail >= 1.4.0

Description: Updated for new stable version (1.4.0)

Version 1.5
by Seth Randall on Jan 7, 2003
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: SquirrelMail >= 1.2.8 and some version of poppassd

Description: Added courierpassd from Andrew St. Jean

Version 1.4a
by Seth Randall on Dec 18, 2002
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: SquirrelMail >= 1.2.8, poppassd

Description: Removed some debugging code I had entered. Added a poppassd.c file for some BSDs

Version 1.4
by Seth Randall on Sep 26, 2002
[ change_pass-1.4-1.2.8.tar.gz tarball (8833 d/l) Help ]
Requires: SquirrelMail >= 1.2.8, PAM, poppassd (included)

Description: Updated for 1.2.8. Newer version of poppassd.

Version 1.3
by Tyler Akins on Apr 15, 2001
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: poppassd

Description: Now uses the mail server address instead of only "localhost". Creates proper redirect so a user can change their password twice in a row.

Version 1.2
by Tyler Akins on Feb 6, 2001
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: poppassd

Description: Added a debug mode, better error checking, does not require that you log out after changing your password anymore.

Version 1.1
by Tyler Akins on Jan 21, 2001
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: poppassd

Description: Fixed conflict with fetchmail plugin.

Version 1.0
by Tyler Akins on Unknown
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: poppassd

Description: Initial version.

If you have problems with the download or decompressing...
Internet Explorer
Right-click on the file, then select "Save Target As"
Firefox, Mozilla, Netscape
Right-click on the file, then select "Save Link As"
Opera
Right-click on the file, then select "Save Link Document As"
Lynx and Links
Press "d" on the link to download the file directly.
  • Untarring problems: Your browser might have un-gzipped it for you automatically. Try just "tar xvf" instead of "tar xvfz". Also, the plugins archive isn't gzipped (it is a tarball of .tar.gz files)
  • Macintosh users: Just hold down your mouse button to get the menu instead of right-clicking.
  • If all else fails, seek our help
© 1999-2010 by The SquirrelMail Project Team