SquirrelMail  
Donations
News
About
Support
Screen shots
Download
Plugins
Documentation
Sponsors
Bounties













Security Notice
Phishing campain
Version 1.4.15
Security Upgrade

People have SquirrelMail running under Windows.

[Caution: the following comment might be out of date] Run one of the later versions of PHP (greater than 4.1, but less than 4.3.0 at the suggestion of the developers). Do not use PHP 5 (it works on PHP5 but demands additional setup).

  1. Get a PHP test page to display properly.
  2. Set your SquirrelMail data folder path and permissions correctly.
  3. Set your PHP sessiondata path and permissions correctly and it should work.

Apparently early versions of ISAPI module for PHP often give this error message so upgrade: PHP has encountered Access Violation at xx009098.

Also, the CGI version (php.exe) doesn't seem as reliable as the ISAPI version (php4isapi.dll)


You might also want to check out WindowsDynamicDNS if Win2k clients are having trouble logging into a Linux server.


A working version:

  • Win2k sp2
  • Apache 2.043
  • Merak Mail Server
  • PHP 4.23
  • SquirrelMail 1.4.0

Everything is working with many plugins.


Another working version:

  • Windows XP Pro SP1
  • Apache 2.043
  • Mercury Mail Transport
  • PHP 4.31
  • SquirrelMail 1.4.2

Everything is working with many plugins. The only thing that doesn't work is the total count on the INBOX - it always reads 0.


And another:

  • Windows XP Pro SP1
  • Xitami 2.5b6 (running several virtual hosts)
  • PHP 4.3.4 (as CGI)
  • Mercury Mail Transport v332
  • SquirrelMail 1.4.2

All now seems to work, though I had to alter the header() calls in /index.php and /src/redirect.php as they were supplying relative URLs; converting them to absolute URLs fixed the problem. Note however, that this setup does run very slowly on my old PII-300Mhz machine with only 128Mb of RAM!


  • Windows 2000 Advanced server
  • PHP 4.3.4 (as cgi)
  • Mercury/32 v4.01
  • IIS 5.0
  • SquirrelMail 1.4.2

Had to modify src\redirect.php as detailed somewhere on this site. Spell checker works after tweaking, as detailed somwhere on this site. Everything seems to work fine. Currently trying to get GPG plugin working. Problems seem to be with GnuPG, not GPG plugin.

An update, a long time later (approximately 1 year) the GnuPG plug-in just doesn't work under Windows as no-one has yet to post a working config and the Gnu Plug-in team advises Windows users to refer to the plug-in team for detailed instructions. Kudos to the GPG plug in team, the plug in rocks under "nix platforms.


Windows NT4 with Mercury Mail Transport:

  • NT4 SP6
  • Mercury W32 4.01a
  • Apache W32 1.2.29
  • PHP W32 4.3.4
  • SquirrelMail 1.5.0

Retreated from Apache W32 2.048 due to authentication issues.


  • Windows XP Pro SP2
  • Argosoft 1.8.6.6 w/ IMAP (Argosoft Mailserver Pro)
  • IIS
  • PHP W32 4.3.9
  • SquirrelMail 1.4.3a

Notes: PHP errors when using PHP 5.0.2 installed PHP 4.3.9 working much better.


Great working configuration:

  • Windows Vista
  • Apache/2.2.4 (Win32) DAV/2 ModSSL/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3
  • PHP 5.2.3
  • SquirrelMail 1.4.13
© 1999-2010 by The SquirrelMail Project Team