SquirrelMail  
Donations
News
About
Support
Screen shots
Download
Plugins
Documentation
Sponsors
Bounties













Security Notice
Phishing campain
Version 1.4.15
Security Upgrade

Invalid range end in /home/httpd/html/squirrel/functions/mime.php

This appears to be a problem with glibc. Some users report that these warnings go away if they update to the latest RPM (from an updates.redhat.com mirror).

For those who have tough times updating glibc on Red Hat 7.0, follow these steps: (Thanks to Louis M.!)

rpm --query glibc

This will give you the current version string of glibc that you have on your machine. If you have anything older than version 2.2-12 then you should update your files,

Download the appropriate files (glibc-2.2-12.i386.rpm, glibc-2.2-12.i586.rpm, glibc-2.2-12.i686.rpm, etc.), depending on your system architecure. If you don't know what you have, then just get the package for i386 (glibc-2.2-12.i386.rpm) and it should work just fine. You can download those files by connecting to updates.redhat.com with ftp. Install the newly gotten RPM Package using:

rpm -Uvh glibc-2.2-12.i386.rpm

Things should go smoothly, unless you get some dependency errors, like these:

error: failed dependencies:

glibc-common = 2.2 is needed by glibc-2.2-12

/usr/bin/getent is needed by stunnel-3.8-4

In that case you should download another RPM Package, glibc-common-2.2-12.i386.rpm. Don't try installing it first, because it`ll give you another error message. The right way to do it is like this:

rpm -Uvh glibc-common-2.2-12.i386.rpm glibc-2.2-12.i686.rpm

This will do the trick. You should see the lovely # signs on your screen indicating that the installation process is ongoing. You might get an error message, and you can ignore it since the system is simply trying to update some file which is currently in use. After you are done installing, reboot the machine. Restarting just apache doesn't seem to solve the problem.

© 1999-2010 by The SquirrelMail Project Team